3rd party battery problem in 5DMk4

Started 2 months ago | Questions thread
Muggo
OP Muggo Regular Member • Posts: 223
Re: 3rd party battery problem in 5DMk4

hotdog321 wrote:

Muggo wrote:

I have a couple of no name LP-E6 batteries from my old 6D. In my 6D, they used to perform just as well as a genuine Canon one & allow me to take around 600 shots before recharge was required. However, when I use these batteries in my new 5DMk4, they go flat in approx 85 shots. The Canon charger says they are fully charged before use.

The camera reports 3 green bars on each suggesting the batteries are in good condition, but I'm only getting about 15% actual performance. I have a genuine Canon battery (LP-E6N but only 2 green bars) that gives 600 shots plus.

What's going wrong please? I don't plan to pay top price for a spare genuine Canon one, so what make of 3rd party battery will solve my problem? Should I believe the claims of greater battery capacity from some of the 3rd party ones?

I own two 5D IV bodies with grips (four batteries). When the OM batteries died, I replaced them with RAVPower batteries and they work just fine.

Thanks for the info.

I see RAVPower claim 2040mAh compared with 1800 for LP-E6 or slightly more for N version.  Would you say you get 15% more shots in practice or is it just marketing spin?

 Muggo's gear list:Muggo's gear list
Canon EF 70-300mm f/4-5.6L IS USM Canon EF 24-105mm f/4L IS USM Panasonic Lumix DMC-ZS50 Canon EOS 5D Mark IV Canon EF 35mm F2.0 +6 more
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow