A Workaround for Topaz Sharpen AI Wave Artifacts

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
knickerhawk Veteran Member • Posts: 6,689
A Workaround for Topaz Sharpen AI Wave Artifacts
2

As a number of users of the Topaz AI products have noted, a frustrating problem is the presence of vertical wave-like artifacts. I've seen this myself in several different Topaz AI tools, but it's especially frustrating in the Stabilize option in the Sharpen AI tool because it's so readily visible as wave-like patterns that resonate along strongly contrasting edges, which is also the same areas you want to be sharpened. Some users have noted that the problem is related to using the GPU processing option (set in the Preferences menu). If you, instead, use the CPU processing option, you won't get the strong wave-like artifacts. However, I've also found that the CPU processing option doesn't seem to be as powerful/effective as the GPU option for reducing movement related blur (which is why you'd revert to the Stabilize option in the first place). I've come up with a pretty decent workaround for minimizing the wave artifacts while still using the GPU processing option.

Take for instance this crop of a wedding shot that was taken at a shutter speed that was too slow to stop the movement of the bride as she and the groom were quickly moving down the aisle at the end of the ceremony. Below is the original before processing in Sharpen AI. It's been upsized 200%:

View at 100% in the DPR viewer to see it fully upsized

Below is the same crop after it's been run through Sharpen AI set to Stabilize with CPU processing turned on. For demo purposes I've kept things simple by setting the blur adjustment at +100 and the noise adjustment at +50, which is not necessarily optimal for this particular image:

And below is the same crop with the same Sharpen AI settings except the GPU processing option was used instead of the CPU option:

Note how much more "stabilization" of the hand movement has been achieved. Same can be said for the beaded detail of the dress and the flora in the background. Study the edges around the pit of her arm. They're much better defined in the GPU version BUT they also suffer the wave-like artifacting that's quite visible along these edges in the GPU version. The wave pattern is present throughout the GPU rendering, but less obvious where there's lots of texture.

The workaround involves duplicating the source layer in Photoshop and processing each layer in Sharpen AI with the GPU option on and whatever blur and noise settings you prefer. Before processing the second layer in Sharpen AI, move it horizontally however many pixels equals half the visible wavelength of the artifact pattern. In the image shown here, the wave length is 4 pixels wide, so I shifted the second layer left by 2 pixels. After you've run Sharpen AI on the second layer, move that layer back by two pixels to the right and set the opacity for the second layer to 50% (assuming, of course, that this second layer is on top of the first layer). This has the effect of averaging out the wave artifact pattern without adversely affecting the real signal/detail in the image itself. It may not completely remove the wave pattern, but it should be a rather visible improvement as can be seen below:

Perhaps there are other workarounds or Topaz has fixed this problem in the latest version, which I haven't yet downloaded, but for now this is serving as a workaround for me and I figured I'd share it here, given the spate of Topaz-related threads.

ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow