EM5.3 tripod mount broken - Follow up 2

Started 2 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
LeeHicks Forum Member • Posts: 59
EM5.3 tripod mount broken - Follow up 2
16

This is a second follow-up thread to:

Original thread

First follow-up thread

Basic history:  EM5.3 purchased in USA November 2019.  Now living in New Zealand.  Tripod mount found broken on camera early January 2020.

Timeline:

  • 18 January 2020 - First contact to Olympus America
  • 21 January 2020 - Camera sent to A&E Electronics for Repair
  • 23 January 2020 - Email received from Olympus Australia basically just stating they are now involved
  • 05 February 2020 - Email received from A&E Electronics stating the Olympus AU would pay for PARTS only and I would be responsible for Labor costs (275 NZD ≈ 200 USD). With this deal, the parts then belong to Olympus AU. I accept.
  • 13 February 2020 - Camera received by me.

So, the new information in this post is that after a couple of weeks' delay Olympus AU offered to pay for the parts portion of the repair. There was no communication whatsoever with me to discuss this, no back and forth etc. Only the comms shown on the dates listed above. It is fairly obvious that this move is the cheapest way for them to secure the broken parts. I know many of you will be disappointed that I don't have the parts back so that I can share photos of them. It is my hope that Olympus does something useful with them, like investigate to see if there is an actual problem. Keeping in mind that Olympus had no way of knowing why the camera actually broke, I feel this was a fair offer and I was willing to pay the cost to get the camera repaired and back in my hands.

So, that's the end of the story for now. I plan to sell the camera and purchase an EM1.2 or perhaps an EM1.3 in a few months if the price drops a bit. I personally cannot trust the EM5.3 to not break again since I don't know why it broke the first time.

As a side note, the camera was returned with the menu system completely reset. This is a minor annoyance as I do have quite a few settings customized to my preference. I thought perhaps it was just a new camera body with my old serial number glued to the bottom, but I checked the shutter count and it seems approximately correct.

I am satisfied with the communication with Olympus America and Australia. Not the best customer service I have ever experienced, but more like "meets expectations".  I am very pleased with the service and communication received from A&E Electronics.

Olympus America: 800-622-6372, 888-553-4448, customersupport@olympus.com

Olympus Australia: consumer.repairs@olympus.com.au

A&E Electronics, Christchurch NZ: +64 33721213, service@aeelectronics.co.nz

 LeeHicks's gear list:LeeHicks's gear list
Olympus E-PL9 Olympus E-M5 III Panasonic Lumix G 20mm F1.7 ASPH Olympus M.Zuiko Digital ED 60mm F2.8 Macro Sigma 30mm F1.4 for Micro Four Thirds +2 more
Olympus E-M5 III
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow