Another case of the E-M5iii tripod mount failing

Started 4 days ago | Discussions thread
HRC2016 Senior Member • Posts: 5,161
Re: Plastic-c-c-c-c-c-c

Quite a bit of commotion and a lot of posts to address but here goes:

Someone mentioned that a long lens puts stress in the tripod mount. While this may be true, most long lenses have tripod mounts in the lens. If your lens has a tripod mount you don't use the camera's tripod mount.

But Olympus sells clips to attach straps to the tripod mount!  Yes, but are these failures happening with the Olympus clips? I don't think so. Did PD copy Olympus, or vice versa? Is there a patent infringement situation?

It's only happening with this Oly, so it must be this body!  Not true. There isn't enough data.

When I reported seven bad copies of a Panasonic 100-400, several said it was my body. That was similarly false, as the problem occurred on other bodies.

If you want a solution you need to identify the problem accurately.

I would not recommend hanging a camera body by the tripod mount for this very reason.

-- hide signature --

I believe in science, evolution and light. All opinions are my own. I'm not compensated for any of my posts. Can you honestly say that?

 HRC2016's gear list:HRC2016's gear list
Panasonic Lumix G Vario 45-200mm F4-5.6 OIS Olympus M.Zuiko Digital ED 12-50mm 1:3.5-6.3 EZ Olympus M.Zuiko ED 75-300mm 1:4.8-6.7 II Sigma 150-600mm F5-6.3 | C Olympus 12-100mm F4.0 +2 more
Post (hide subjects) Posted by
NCV
NCV
NCV
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow