Another case of the E-M5iii tripod mount failing

Started 4 days ago | Discussions thread
JakeJY Senior Member • Posts: 3,752
Re: Another case of the E-M5iii tripod mount failing

FrankieB42 wrote:

Expecting we will see more cases like this over time. Photos in last thread clearly showed that Tripod mount in E-M5 mk3 is possible weak point, definitely downgraded compared to even other plastic Olympus body(E- M10 mk3).

And can we please stop with forum members trying to shift blame on PD plate? If it worked fine with dozens of other camera models, if it worked great with previous Olympus models(I have it on my E-M10 mk2 often) and suddenly problems starts to show up with just this model, I think we can see where the issue should be.

The design looks very similar to the E-M10 II's and I'm not sure there is any evidence they downgraded the plastic. The major difference is that the E-M5 III has the bottom port for the grip, which may be a possible source of weakness.

As for the PD plate, it's not necessarily blame, but there may be a possible factor in its design that makes it easier for it to rip out the tripod mount (I double checked and sure enough the other failure was also using a PD plate).

In general tripod mounts aren't designed to be pulled from the bottom (they are designed to mount the camera and lens on tripod), so not sure if there would be any possibility to claim it is Olympus's fault if it fails from such usage. Some people refuse to use tripod mount straps for the same reason.

 JakeJY's gear list:JakeJY's gear list
Nikon Coolpix S9300 Nikon D5000 Panasonic Lumix DMC-GX85 Nikon AF-S DX Nikkor 55-200mm f/4-5.6G VR Nikon AF-S DX Nikkor 18-55mm f/3.5-5.6G VR +5 more
Post (hide subjects) Posted by
NCV
NCV
NCV
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow