Another case of the E-M5iii tripod mount failing

Started 3 days ago | Discussions thread
Wu Jiaqiu
Wu Jiaqiu Forum Pro • Posts: 25,410
Re: Not Olympus fault
13

HRC2016 wrote:

I don't see how this is Olympus' fault. Users are using the tripod mount for something for which it is not designed. It's a tripod mount. Does this not securely mount the camera on a tripod?

Just because after-market products can use this threaded hole does not mean they should.

Certainly, if Olympus wanted to redesign this area (knowing about these after market producfs), it has that option. Alternatively, there could be a warning in their owners manual about not using the tripod-mount hole to attach the camera to a strap. There may already be a warning.

I've refrained from hanging my camera by the tripod mount for this very reason - it's not designed for this use.

It's not a safety issue. A recall isn't warranted, in my opinion.

I appreciate the OP and others speaking up, to alert other users of these types of issues. None of us want to see a damaged camera, but when one is damaged we should look in the right direction for the cause and solution.

how many other cameras carried this way or used this way have suffered a similar failure?

-- hide signature --

the computer says no

 Wu Jiaqiu's gear list:Wu Jiaqiu's gear list
Fujifilm FinePix X100 Nikon D2Xs Nikon 1 V1 Nikon AF-S Nikkor 300mm f/4D ED-IF Sigma 70-200mm F2.8 EX DG Macro HSM II +1 more
Post (hide subjects) Posted by
NCV
NCV
NCV
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow