Another case of the E-M5iii tripod mount failing

Started 4 days ago | Discussions thread
HRC2016 Senior Member • Posts: 5,161
Not Olympus fault
20

I don't see how this is Olympus' fault. Users are using the tripod mount for something for which it is not designed. It's a tripod mount. Does this not securely mount the camera on a tripod?

Just because after-market products can use this threaded hole does not mean they should.

Certainly, if Olympus wanted to redesign this area (knowing about these after market producfs), it has that option. Alternatively, there could be a warning in their owners manual about not using the tripod-mount hole to attach the camera to a strap. There may already be a warning.

I've refrained from hanging my camera by the tripod mount for this very reason - it's not designed for this use.

It's not a safety issue. A recall isn't warranted, in my opinion.

I appreciate the OP and others speaking up, to alert other users of these types of issues. None of us want to see a damaged camera, but when one is damaged we should look in the right direction for the cause and solution.

-- hide signature --

I believe in science, evolution and light. All opinions are my own. I'm not compensated for any of my posts. Can you honestly say that?

 HRC2016's gear list:HRC2016's gear list
Panasonic Lumix G Vario 45-200mm F4-5.6 OIS Olympus M.Zuiko Digital ED 12-50mm 1:3.5-6.3 EZ Olympus M.Zuiko ED 75-300mm 1:4.8-6.7 II Sigma 150-600mm F5-6.3 | C Olympus 12-100mm F4.0 +2 more
Post (hide subjects) Posted by
NCV
NCV
NCV
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow