Samyang 85mm f1.4 on A7R4 - Strange audio noise problems coming from the lens autofocus

Started 3 weeks ago | Discussions thread
ForumParentFirstPrevious
Flat view
DJDream Regular Member • Posts: 249
Samyang 85mm f1.4 on A7R4 - Strange audio noise problems coming from the lens autofocus

Hi guys,

I just bought a Samyang 85mm f/1.4 lens and I am very pleased about its picture quality.

What I am not pleased is the fact that this lens is so noisy that I'm suspecting I got a BAD copy. This lens is has always a noise while it is set on Continuous Focus, less on Single Focus Mode. It looks to has the same strange noise also during autofocus in video mode.

I am posting a video that I found on youtube that is reporting the same issues.

I have the v4 Firmware on it, the last one available.

I would like to ask the owners if you face the same noise on the described situations or it is just my lens that is bad. Again, related to the results, these are amazing, but still the focus noise is disturbing me.

Whats's your opinion on it? Should I ask for a replacement or all the other copies have the same issue?

The video ( I only have the noise problem but not the other presented on this video):

https://www.youtube.com/watch?v=HBFnOIEBoN0

Cheers!

 DJDream's gear list:DJDream's gear list
Samyang AF 85mm F1.4 FE
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow