Can't update GX80 firmware - The disk is write-protected

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
Olovs New Member • Posts: 22
Can't update GX80 firmware - The disk is write-protected

Hello guys,

So I finally bought the GX80. But, of course, there are some issues.

I want to update to the latest firmware. I connected the camera with my laptop, using the usb cable that was delivered with the camera.

But I can't write on the SD-card, it says "The disk is write-protected". So I can't add the firmware update, nor delete any files. Just copy files. In other means, it's "read only".

What I have tried so far:

- Turn on/off the physical switch on the SD card.

- Tried on 3 different laptops (all Windows)

- Reboot laptops and camera

- Format SD-card through the camera

- Added WriteProtect 0 value in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\

- Performed a diskpart from the cmd-line - DISKPART> attributes disk clear readonly

- Given my account admin rights to share/use the SD-card

- Installed and used EeaseUS tool
- Been at the camera shop and exchanged the SD card for a new one - still same problem!
The SD-card I have is: SanDisk Extreme PRO SDXC UHS-1 64 gb 170 mb/s.
Any ideas?
Thanks in advance.

Panasonic Lumix DMC-GX85
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow