Very slow location data refresh rate between snapbridge and a Z50

Started 3 weeks ago | Discussions thread
ForumParentFirstPrevious
Flat view
Rolmat Junior Member • Posts: 39
Very slow location data refresh rate between snapbridge and a Z50

Hello from France (sorry for my not perfect english)
I just got a Z50, and wanted to try snapbridge's function allowing to add the location data  (longitude and latitude) to the photo's exif data.
I had no problem to set the bluetooth connection between the Z50 and my Android phone (Samsung J7), and all seems to work as advertised.
The only problem I have is that the refresh rate of the location data is very slow, in fact when going to the "Location data display" in the SETUP MENU, it appears that the data is refreshed only about every 2 minutes.
Same when I take several photos in a short time, they have all exacly the same location data showing.
I first tought it may be some "energy managment" problem on the phone but even when using the phone it's the same.

Even more strange, after I stop Snapbridge on the phone and the bluetooth connection (on both devices) the "Location data display" info continues to show me the last known position (as I write this, I stopped the connection half an hour ago and I still have my old location data). And they are also added to the photos I take.
So actually this location data thing is rather useless...
Do others have the same behaviour with snapbridge ?

Roland

 Rolmat's gear list:Rolmat's gear list
Nikon D800 Nikon 1 J5 Nikon Z50 Nikon AF-S DX Nikkor 55-200mm f/4-5.6G VR Nikon AF-S Nikkor 24-120mm F4G ED VR +4 more
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow