Problems with DXO Photo Lab 1

Started 11 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
Searching Veteran Member • Posts: 3,799
Problems with DXO Photo Lab 1

Didn't use it for a while.  Using Windows 10 64bit.  Clicked on the shortcut icon about two weeks ago and the Photo Lab log on screen appeared and then disappeared and nothing happened, wouldn't open, no error messages, nothing.

Support said to erase all DXO files and downloand the app Photo Lab 1 program again.

Went through the process and exact same thing happened again.

Support said to down load and send them all kinds of crash logs, download another program to detail the crash and to copy and send all kinds of files which they would have their development team look at.

I think they are just trying to get rid of me as a customer because its PhotoLab1.  Support doesn't reply to the tickets you submit in a timely fashion.  I had to submit 3 tickets waiting before I got their final reply.  I give up.  I wont buy any DXO products again.  I can't be the only person who has had this problem.

Does anyone know of any solutions?  Thank you.

 Searching's gear list:Searching's gear list
Olympus E-M1 II Olympus M.Zuiko Digital ED 40-150mm F4-5.6 R Olympus M.Zuiko Digital 45mm F1.8 Olympus M.Zuiko Digital ED 12mm 1:2 Olympus M.Zuiko Digital ED 75mm F1.8 +3 more
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow