Terrible sensor flaring with a7Riv

Started 1 week ago | Discussions thread
ForumParentFirstPrevious
Flat view
Matt_1423 New Member • Posts: 12
Terrible sensor flaring with a7Riv
9

I'm new to Sony and mirrorless, coming from a Canon 5Div. I've noticed terrible sensor flaring with my new a7Riv, creating a grid of green polka dots all over the image when shooting into the sun with apertures above f/8. It happens with all lenses I've tried, to varying degrees, including the Sony 24-70 GM, as well as my adapted Canon 16-35 and Tamron EF 24-70 G2. On all lenses, shooting with the sun above f/8 looks pretty much like garbage.

I'm used to shooting at small apertures and getting gorgeous sunstars that I incorporate into my images. It seems that it's basically impossible on the a7Riv unless I'm missing something or my body has something wrong with it.

I'd appreciate any feedback!

24-70 GM @ f/22

24-70 GM @ f/22

https://photographylife.com/fuji-x-trans-flare-ghosting-issue

I found this link related to sensor flare for Fuji bodies, which seems to be similar to what I'm experiencing. The advice is to not shoot at small apertures, or keep the sun in the center of the frame, or just don't shoot the sun. All of this is extremely depressing if I really can't use my a7Riv to get nice sunflares.

Sony a7R IV
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
CE3
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow