Broken Panasonic 100-400 lens - an update

Started 1 week ago | Discussions thread
ForumParentFirstPrevious
Flat view
keithinmelbourne
keithinmelbourne Contributing Member • Posts: 950
Broken Panasonic 100-400 lens - an update
34

Well, after a somewhat torturous process, my lens has been fixed and returned. I have tested it, and it is working perfectly. When I picked up, the shop manager said that the repairman had to go around Panasonic in order to get the parts (although he wasn’t very specific about how). As it turned out, I had not only broken the mount, but also a circuit board. In all, the repair cost $460 AUD or about $300 US.

The lens focuses perfectly with both my Olympus bodies. I haven’t tried it on my G9 yet, but it shouldn’t be a problem. I should also say that the new mount fits my Olympus bodies perfectly now, whereas the lens was very tight before. Needless to say, I am now a much happier camper.

-- hide signature --

Every day is a good day! Wumen
“The privilege of a lifetime is being who you are.” Joseph Campbell
http://www.keithbroadphotography.com/

 keithinmelbourne's gear list:keithinmelbourne's gear list
Fujifilm X100F Olympus TG-5 Olympus E-M1 II Panasonic Lumix DC-G9 Olympus OM-D E-M1X +14 more
Olympus E-M1 II Olympus OM-D E-M1X Panasonic Leica 100-400mm F4.0-6.3 ASPH Panasonic Lumix DC-G9
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow