Pink spot in video footage (only in cold weather), sensor damage or not?

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
tim21 Regular Member • Posts: 104
Pink spot in video footage (only in cold weather), sensor damage or not?

I have an EOS M5 and have noticed that there is a quite big pink dot in my video footage (right in the centre), only when the weather is cold it seems. I have done some timelapses with it but the sun was out of the shot for basically all of them, and they were done late in the after noon in winter, so I am having a hard time believing that the sun damaged the sensor.

Any other ideas what it could be? What could have caused it? The camera automatically cleans the sensor and I have used a blower on the sensor and the lens, and tried another lens, but the pink dot still reappears in cold weather. It doesn't seem to show when I take a photo though.

Any idea whether canon have warranty for that sort of malfunction? I guess they'd be reluctant to include that sort of thing in their warranties. It is quite a concern, as I have treated this camera like my baby, and still this happened. It's definitely not a dead pixel in the screen as I was hoping, as I have reviewed the footage on my computer.

I will take it into the store, but I don't like my chances of much help, hence asking you good honest folk here for your thoughts.

ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow