Weird semi stuck shutter problem

Started 1 month ago | Discussions thread
ForumParentFirstPreviousNext
Flat view
DMillier Forum Pro • Posts: 21,151
Weird semi stuck shutter problem

Hi People

I wonder if anyone can help me out.

I have an ancient Kodak DCS 14n which is a full frame DSLR from around 15 years ago. The body is based on a modfied/customised Nikon F80/N80 film camera in much the same way as the D100.

I'm asking here because the base camera is a Nikon (and because the Kodak forum is pretty much dead). I'm hoping the fault is something Nikon owners have come across before.

What is happening is the camera starts booting up and then stops with "Err" flashing on the top plate LCD and in the viewfinder. I can see on auxiliary rear LCD that the camera is cycling constantly through reboot cycle. At this point it sounds like it is the Kodak half of the camera that is the problem....

... however, the camera does partly function (at least the Nikon half does). If I jamb my finger on the shutter release, a repeated clicking noise emanates from the body and eventually the mirror flips up and the shutter fires. However, the mirror stays up. If I continue holding the shutter button, the clicking continues and there is a regularly flashing red glow from the focusing screen (AF point illuminator) and the shutter blades slowly inch their way shut step by step until the mirror drops down.

I've been playing with it for a while and once or twice the "Err" cleared and the shutter speed and aperture displayed on the top LCD. But tripping the shutter again repeated the cycle.

Anyone experienced this with a nikon body?

-- hide signature --
Nikon D100
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNext
Flat view
Post (hide subjects) Posted by
ForumParentFirstPreviousNext
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow