DXO terrible upgrade policy

Started 2 months ago | Discussions thread
Holger Bargen Veteran Member • Posts: 3,697
Re: DXO terrible upgrade policy

Lacko wrote:

Holger Bargen wrote:

If you buy a new camera it may not be supported with your DxO version and you have to do the upgrade - even though the latest version is almost same (in my opinion even worse) compared your version which may be just 1 year old.

Cameras (lenses) are supported with DXO Optics modules which can be downloaded into any DXO version.

Only the lenses can be loaded and there seems to be no limit. But if you try to process a RAW file from a camera that is not on the list of the old DxO version you can't do nothing with that file. It is not just about the support of certain camera-lens combinations which I would accept to be only available for the latest program version - it is even about basic processing steps where no special modules are needed.

 Holger Bargen's gear list:Holger Bargen's gear list
Pentax K-5 Pentax K-S1 Pentax K-1 Pentax smc DA 55-300mm F4.0-5.8 ED Sigma 70mm F2.8 EX DG Macro +6 more
Post (hide subjects) Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow