E-M1X Firmware v1.1 - Update Experience

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
PeterSimpson Junior Member • Posts: 41
E-M1X Firmware v1.1 - Update Experience

Edited to clarify USB port experiences.

Olympus have posted a revised E-M1X firmware version 1.1. Functionally the firmware just adds a feature to speed up image processing in Olympus Workspace.

It's possible that there are undocumented fixes in the update, but I was disappointed that the release notes make no mention of stability improvements that could address the occasional lock-ups that i and several others have experienced.

tl;dr

Summary experiences and learnings from updating my camera:

  1. Use a USB2 port rather than a USB3 port
  2. Be prepared to wait the 4-5 minutes that it takes for the camera to update when it is displaying the "Camera Update" dialogue (Two circular arrows, white hand in a red circle with diagonal bar)
  3. Be prepared for the possibility that you will need to set the date and time again.
  4. Be prepared for the possibility that your presets may or may not be fully restored.

Main Post

My update experience hasn't been smooth but I have now got there successfully so I thought I'd report what happened to help others.

i run Windows 10 and to update the camera I used the just released Olympus Workspace 1.1, which contains camera updater v2.2. Initially I used a USB3 port to connect the camera to the PC, which activated the camera's USB battery charging and both charge lights came on.

The update started out fine with a dialogue box saying "Updating the firmware", but an error box appeared saying: "Failed to communicate with the camera (0x80070005)". Fortunately the camera was not bricked and powered up with the original firmware. I tried again with the same outcome.

After the failure, I noticed that the battery level, visible in the top left of the camera view screen showed as 0%, which was incorrect, the battery actually reports over 90% charge in normal use.

I guessed that the USB3 power charging may have interfered with the update so I tried again using a USB2 port. This approach was successful and the camera updated to firmware 1.1.

I had to wait about 5 minutes though for the update to complete with the "Update Camera" dialogue showing on the camera screen... it was difficult to resist the temptation to assume that the update had failed!

Lastly the automatic preset restore that worked faultlessly when updating my E-M1 Mk2 also failed with a missing file message.

When I powered the camera back on I was presented with the initial configuration screens to set the date and time but after setting these I found that my presets were still in place. I'll probably reset the camera to default settings later and reconfigure it just to make sure all is OK

Oh well, at least its done!

 PeterSimpson's gear list:PeterSimpson's gear list
Olympus E-M1 II Olympus OM-D E-M1X Panasonic Leica 100-400mm F4.0-6.3 ASPH Olympus M.Zuiko 300mm F4 IS Pro Olympus 12-100mm F4.0
Olympus E-M1
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow