D850 long exposure noise with NR enabled

Started 1 month ago | Discussions thread
ForumParentFirstPreviousNext
Flat view
primeshooter
primeshooter Veteran Member • Posts: 5,043
D850 long exposure noise with NR enabled

I do a lot of long exposure work, and with the D810 (which I still use regularly in combo with the 850) I have long exp NR enabled. This mean's post is eaiser as the all hot pixels that can appear as the sensor heats are subtracted, at the cost of doubling the waiting time of course. The shots come out clean with no issues,

However, with the D850, with this enabled, I am still seeing little specs scattered about - not millions of them but enough for it to be a pain cloning them out? What the heck is going on with this? They can be white blue or red (probably green somewhere but not seen any yet), not sure I've seen any other colours. We are talking a low mileage D850 I've had from new and exposures during day from 30 secs to usually max 4-6 mins but even on the lower end of the scale it's there. Pretty sure it's a feature not a defect but wondering why?

I found this - https://diglloyd.com/blog/2017/20171229_1844-NikonD850-noise-LENR.html

What do people here that use this do? I know folks shoot the d810 with it off but I like using it, because without it I get a huge mass of hot pixels and I prefer to have it all cleaned at the scene whilst I shoot with the other camera in the waiting period.

Nikon D810 Nikon D850
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNext
Flat view
Post (hide subjects) Posted by
ForumParentFirstPreviousNext
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow