Is this normal behavior for the Godox TT685N when powering up while on the camera?

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
Razor512
Razor512 Regular Member • Posts: 209
Is this normal behavior for the Godox TT685N when powering up while on the camera?

When the Godox TT685N is on the hot shoe of the Nikon D5600, during the power on process of the speedlight, the zoom motor will roughly step through its zoom range rather than smoothly moving through it.

If the speed light is taken off of the hotshoe, or if it is turned on while the camera is off, then it will smoothly move through the zoom range of the flash head.

Aside from that it functions fine (both auto and manual zoom, though I only use the manual zoom, and don't really plan to use it as an on-camera flash.

My previous use was with a non-ttl yongnuo speed light which I gave to my brother. With the TT685N being a pretty good deal for fairly compact speed light, I decided to get it, and then get a cheap used wireless trigger (waiting for delivery).

Anyway, I was just wondering if that powering up behavior was normal for this speed light when turned on while mounted on a camera that is already turned on.

I recorded a video of the behavior. https://www.dropbox.com/s/23611pyfthp6kib/TT685N%20noise.mp4?dl=0

The speedlight is running the latest 3.2 firmware.

 Razor512's gear list:Razor512's gear list
Nikon D5600
Nikon D5600
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow