DT Gurus : Darktable is not using my PC at its full potential

Started 1 month ago | Questions thread
sluggy_warrior Senior Member • Posts: 1,573
Re: Solved !!!
2

tokumeino wrote:

sluggy_warrior wrote:

opencl_device_priority=!1,*/!0,*/0,*/0,*

Indeed, these settings appear the lost balanced?

I also have GTX 1050Ti and Intel 630. I was playing around in settings, and found that the "opencl_device_priority" setting only takes effect if you set "OpenCL Scheduling Profile" to "default" in preferences. If you select "Multiple GU" or "Very fast GPU", it'll ignore the "opencl_device_priority" setting.

You can verify the actual device priority by running darktable with "-d opencl" flag. Upon startup, the log will have these entries (I set mine to '!0,*/!1,*/1,*/1,*' as the Intel is 0):

0.231122 [opencl_priorities] these are your device priorities:
0.231124 [opencl_priorities] image preview export thumbnail
0.231127 [opencl_priorities] 1 0 1 1
0.231130 [opencl_priorities] -1 -1 0 0
0.231146 [opencl_priorities] show if opencl use is mandatory for a given pixelpipe:
0.231148 [opencl_priorities] image preview export thumbnail
0.231151 [opencl_priorities] 0 0 0 0

As you edit the photos, the log should show "[full] using device 0"  and "[preview] using device 1" for you.

Post (hide subjects) Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow