A630 Sigma Lens with Commlite Adapter?

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
Okay Emmanuel
Okay Emmanuel Forum Member • Posts: 63
A630 Sigma Lens with Commlite Adapter?

Hey everyone so I recently purchased a commlite adapter for Nikon lenses (ENF-E1) because it was pretty cheap on eBay (got it for $50 as the seller said it was "hit or miss" with their lenses) and I'm testing it with my Nikon Sigma lenses - the only Autofocus lenses I have - and none of them really work. At least consistently. I have a 17-70 2.8-4 and a 10-20 4-5.6. For the first day, I had the adapter the 17-70 autofocused surprisingly well (I can post the pictures if anyone wants to see them), but the 10-20 didn't autofocus at all. Now - about a week in - neither of the lenses autofocus. When I hold down the shutter button both of them immediately go to infinity focus and don't move from there.

Does anyone else have any experiences with using Sigma lenses with this adapter? Is there any way I can fix this? (The Adapter firmware is V.06 btw)

Thanks

Using the adapter with my Sony A6300.

 Okay Emmanuel's gear list:Okay Emmanuel's gear list
Nikon D7100 Sony a6300 Nikon AF Nikkor 50mm f/1.8D Sigma 10-20mm F3.5 EX DC HSM Sigma 17-70mm F2.8-4 DC Macro OS HSM | C +3 more
Canon PowerShot A630 Sony a6300
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow