New updates for Sony cameras (3.01 not 3.00) released

Started 1 month ago | Discussions thread
TX4716 New Member • Posts: 6
Re: The update bring back the 3rd party battery message or not?

araudan wrote:

RondaArouseMe wrote:

Magnar W wrote:

RondaArouseMe wrote:

Magnar W wrote:

RondaArouseMe wrote:

Is there another way to update other than USB? I can never connect to mass storage.

I just get the notice "check connecting device" on my A7ii.

Try using the cable that came with the camera or a different usb cable. Not all cables have the needed connectors. Also be sure the camera is set to "mass storage" by the menu.

I dont have that cable that came with it, just the one that was sent with the camera when i bought it used. Doesn't the one that came with the camera say Sony on it? This one doesn't.

No Sony label on the original cable.

Be sure to use a cable that is not only for charging.

Camera is set to Mass Storage

Should be good!

It's the same cable that does charge the camera but its not working. I pulled it out and tried 3 other micro usb cables and same message "check connected device"

If the cables you have aren't working you may need to purchase another one. I have a cable from Amazon basics. It worked fine. AmazonBasics USB 2.0 A-Male to Micro B Cable (2 Pack), 3 feet The link is to the Canadian Amazon site but I'm sure the US site would have it as well.

Only other thing I can think to ask is if you've tried using another USB port?

Try to use a POWERED USB hub to connect computer with Sony camera. It will solve the issue.

Post (hide subjects) Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow