A-Mount

Started 2 months ago | Discussions thread
cgarrard
OP cgarrard Forum Pro • Posts: 15,677
Re: Btw... the A58

QuietOC wrote:

cgarrard wrote:

QuietOC wrote:

cgarrard wrote:

Interesting.

I totally missed that you were asking about the A58. It is no longer listed on Sony.com.

No worries at all, you weren't the only one.

I started with the A58 in early 2015 when Sony had it on sale with the 18-55 for $400 and $150 discounts on the 55-200 and 55-300. It was already being closed-out then. I am sure being my first real camera colors my opinions.

Now I've tried an A57 and A65 I can see that it was more of an A38, but the viewfinder is nicer than those earlier, higher end models. I still prefer a simple tilting rear screen.

Issues: tiny buffer that often shrank, 20 MB/s SD writing (like previous models), aliasing with video and stills.

I appreciate you taking the time to give feedback on it. The last SLT I owned was the A57 I think. Prior to that I recall going to the press event with Sony in San Diego to test out the NEX 7/A77/A65 cameras, they sent me some for review after. Never got around to reviewing them because they didn't seem "finished" firmware wise. From memory, the A57 was the most polished of them all- however I missed the A77ii/A58/A68 announcements completely.

-Carl

Yeah, the A65 had a bug in the focus magnifier when you moved to the edge the display wouldn't update until you reversed the direction a step. I think they miscalculated the sensor size or something. The cameras since then stop the scrolling before the error happens, but you still can't see the edges of the sensor.

The A65 would occasionally misexposure shots after the shutter was already pressed. It was really annoying for me when testing lenses. Not very noticeable in other uses.

Both of those issues were fixed by the A58 at least. The A65 sure sounds impressive on paper.

That's good

Several cameras have some sort of memory bug with I believe the Distortion Compensation. The A58 would get down to only being able to capture 3 or 4 frames in the buffer. The Sony customer service team seemed aware of it when I called. Reseting the camera got the buffer back to 6 frames.

Sounds like oversight on firmware or something.

The A77II has needed the A6300 updates since before the A6300 was released. We should have 8 FPS live-view, dual gain, AF-C Eye AF, etc.

Tell me more about that? Again, I'm very much behind on all things SLT. I am considering doing an SLT review and still can't decide which model, almost got the A77II... however now... not sure

-- hide signature --
Post (hide subjects) Posted by
EXX
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow