D850 problem

Started 1 month ago | Questions thread
ForumParentFirstPrevious
Flat view
Colin Franks
Colin Franks Senior Member • Posts: 1,623
D850 problem

I’m experiencing an odd thing with my new D850, and wondering if anyone might have an idea what’s going on and how to fix.

I took this body and two brand new Tamron G2 lenses (24-70 f/2.8 / 70-200 f/2.8) on a recent two-week trip to Morocco. For this street type of shooting, I prefer to be in Aperture mode, and manually adjust ISO as needed. I discovered that we can select “Easy Exposure Compensation” with the D850, which means we don’t have to push the EC button, just rotate the rear wheel as needed – awesome! (I set it to “ON”, not “Auto ON”).

Soon into the trip, I discovered that the EC adjustment would sometimes go all wacky, meaning that the EC levels shown in the viewfinder would not correlate to what I was doing with the dial, it seemed to have a mind of its own, going all over the place, and at times not even go one way or the other no matter what I did with the dial. This happened with both lenses, so I suspect that the problem is in the body.

I would remedy the problem by powering the camera off and on again, but sometimes even that didn’t work.

Any ideas?

 Colin Franks's gear list:Colin Franks's gear list
Canon EOS 7D Mark II Nikon D850 Tamron SP 70-200mm F/2.8 Di VC USD Nikon AF-S Teleconverter TC-14E III Canon EF 100-400mm F4.5-5.6L IS II +7 more
ANSWER:
This question has not been answered yet.
Nikon D850 Panasonic Lumix DMC-G2
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow