Sony a7III + 16-35 GM = dust in the sensor?

Started 4 weeks ago | Discussions thread
ForumParentFirstPrevious
Flat view
aleixandrus
aleixandrus Regular Member • Posts: 283
Sony a7III + 16-35 GM = dust in the sensor?

Hi! I've recently bought an a7III and the 16-35 f2.8 GM. This is my only lens for this camera so I didn't swap lenses at all. It is supposed to be a robust and well sealed combo. However, this is what I found:

24mm f20 25s + screw-in ND 6 stops . Full res

Lightroom showing dust points

Dust corrections in Lightroom

Slightly edited image (dust spot corrected). Full res.

Is this normal? It is supposed to be sealed. Where the dust come from? Did I have a defective item? Lens? Camera? I know this shot is at f20, I was playing with long exposure and the 6-stop filter was not enough, so dust is more visible. However, dust is there. This is the second time it happened to me in a very short time (<2 months). I was in some harsh conditions (light rain, snowed terrain but clear day, very strong wind...) but I also have an a6000 with the Samyang 12mm f2 (not sealed at all) and I didn't suffer a problem as drastic as this in three years.

Could you please write down your thoughts?

-- hide signature --

Some of my photos: http://instagram.com/aleixandrus
Twitter/Facebook/Flickr/500px: @aleixandrus

 aleixandrus's gear list:aleixandrus's gear list
Sony a6000 Sony a7 III Sony E 16-50mm F3.5-5.6 PZ OSS Sony FE 16-35mm F2.8 +1 more
Sony a6000 Sony a7 III Sony FE 16-35mm F2.8
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow