E-1 overexposes when lens is beyond base FL and I'm out of ideas

Started 1 month ago | Questions thread
ForumParentFirstPrevious
Flat view
SterlingBjorndahl Senior Member • Posts: 2,093
E-1 overexposes when lens is beyond base FL and I'm out of ideas

I have done a factory reset. I have cleaned the contacts. I am out of ideas. Is my E-1 body faulty?

I have tried 2 zooms (Oly 14-54 and Pana-Leica 14-50) and in both cases it only exposes properly at the widest focal length. As soon as I start to zoom in, it starts to overexpose. By full zoom it's at least 3 stops overexposed.

I've tried the 25mm and 50mm primes. They're fine on their own, but in both cases if I add the EC-14 they overexpose. At least with primes it's more practical to dial in compensation than with zooms.

This happens in all modes - P, A, S, and even M if I follow what the internal meter thinks it's seeing.

I've had this body for several years and this is a new development.

Does anyone have any other ideas?

Thanks,
Sterling
--
Lens Grit

 SterlingBjorndahl's gear list:SterlingBjorndahl's gear list
Olympus Air Panasonic Lumix DMC-GX85 Panasonic Leica D Vario-Elmar 14-150mm F3.5-5.6 Asph Mega OIS Panasonic Lumix G X Vario PZ 14-42mm F3.5-5.6 ASPH OIS Panasonic Lumix G Vario 14-140mm F3.5-5.6 O.I.S +16 more
ANSWER:
This question has not been answered yet.
Olympus E-1
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow