Need to vent P600 Clogs

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
GreatWhiteWing Contributing Member • Posts: 875
Need to vent P600 Clogs

No replies needed. I have asked many times and done all the stuff I am supposed to.

Effing thing is clogged again. I print purge sheets every two or three days and as soon as I want to use the POS it's clogged again.

Purchase and rerun setup utility, get in clear next time I want to use it, you guessed it clogged again.

I don't know if I got some dud but this is beyond frustrating and of course out of warranty.

PC inks and followed every piece of advice from them and still effing clogs

It might be sledge hammer time

Not every color. Used to be a lot of issues with VM. The cartridge leaked recently and made a minor mess. Replaced cart and now the effing black (either one) is effing clogged.

Run a few cleaning cycles, nothing. Switch back and forth, still clogged.

Now I am soaking heads with a Windex soaked paper towel.

Tomorrow may have a sledge hammer party. I'll take pics and send em to Epson

 GreatWhiteWing's gear list:GreatWhiteWing's gear list
Canon EOS 7D Mark II Canon EF-S 10-22mm F3.5-4.5 USM Canon EF 24-70mm F4L IS USM Tamron SP 1.4X Pro Teleconverter Tamron SP 70-200 F2.8 G2 +2 more
Nikon Coolpix P600
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow