Godox xpro transmitter (flashpoint r2 pro) not working

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
bebemaster Forum Member • Posts: 73
Godox xpro transmitter (flashpoint r2 pro) not working
1

Just got an R2 Pro O transmitter and despite whatever settings I used it would NOT fire any of my flashes, tt350, 680ii, or AD200. I was able to get both the tt350 (r2 zoom mini), and the 680ii (r2 zoom li-on) to control the group so it was an issue with the transmitter. Pressing the test fire button did nothing but blink the green then orange indicator light. So I worked though this issue; I changed the ID to off (hit menu then scroll to the last "page") and everything worked. This wasn't at all clear and hopefully it will help others out. Firmware was upgraded to version 1.1 which is the latest listed at adorama although I've read that godox has a 1.3 version out. I've bricked flashes before by upgrading incompatible firmware so I'll be sticking with 1.1 for now.

Tldr: r2 transmitter not working, turn ID to "off" on the third page of the menu.

 bebemaster's gear list:bebemaster's gear list
Panasonic Lumix DMC-GM1 Panasonic Lumix G 20mm F1.7 ASPH Olympus M.Zuiko Digital 45mm F1.8 Olympus M.Zuiko Digital ED 12mm 1:2 Olympus M.Zuiko Digital ED 60mm 1:2.8 Macro +4 more
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow