Misbehaving P1000

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
DAP MV
DAP MV Regular Member • Posts: 200
Misbehaving P1000
4

My P1000 started misbehaving.

A zoom lag appeared at the end closer to the long focal lengths. Usually after you let go the lever (either on top of the camera, or on the side of the lens), the lens stops moving almost immediately. In my camera it kept moving for good fraction of a second before it stopped, thus "overshooting" desired focal length setting.

Since I went through a similar problem with P900 (albeit not zoom related), I knew what to try. In such a situation before sending a camera to the repair shop, one should try the following: re-flash the firmware, reset all settings to default, take the battery off and allow internal cap to discharge completely (i.e., force clean slate start).

In my case re-flashing the firmware did nothing, but resetting all camera setting to default did the trick: the zoom started working as it should. (Later I had to spend 1/2 on restoring configuration of the camera back to my preferred settings, but it was a small price to pay.)

I though I would share it in case somebody runs into similar problem.

-- hide signature --

Darius

Nikon Coolpix P1000 Nikon Coolpix P900
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow