a6500 issue

Started 7 months ago | Discussions thread
Ray Maines
Ray Maines Veteran Member • Posts: 4,114
Re: a6500 issue

wine540 wrote:

wine540 wrote:

I got a new a6500 from B+H. Loved the camera,size,form,factor,handling etc. but after a day started to get the error message: "Camera error. Turn camera off and then back on again." That didn't work, but removing the battery and replacing it always did. I returned the camera to B+H.

This issue was discussed in this forum for the a6000. I did some research and discovered that this is a commonly reported problem for the whole "a" series. Never happened with my a7iii though. I contacted Sony and they advised to return the camera for repair if the problem occurs repeatedly.

Is this going to pop-up sometimes later? Is it a QC issue for just some cameras. I don't know what to make of this. Never had the problem with Nikon, Olympus, Panasonic or Canon.

I am looking for a perspective on Sony cameras with regard to QC and stability. ?time to look for another brand.

Exchanged it at B+H - no hassle - full credit and return shipping. Replacement a6500 works perfectly.

Glad to hear that. Keep us posted.
Actually, I've not read about this being a problem on anything besides the a6000

-- hide signature --

I own a camera, I don't belong to a tribe.
Tacoma, Washington, USA

 Ray Maines's gear list:Ray Maines's gear list
Sony a6300 Sony 70-300mm F4.5-5.6 G SSM Tamron SP AF 90mm F/2.8 Di Macro Sony Carl Zeiss Sonnar T* E 24mm F1.8 ZA Sony E 50mm F1.8 OSS +14 more
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow