Lumix G9: Any solution to video CAF problems?

Started 10 months ago | Questions thread
Adrian Tung
Adrian Tung Veteran Member • Posts: 3,717
Re: Sure ...

Kawika Nui wrote:

Thanks for doing the testing. Are you in Video mode (on the dial) and using the shutter button to shoot? Or are you using the video button to shoot?

I use the dedicated video mode.

I've tried using the shutter button to get the focus back and it works, but obviously it would be preferable to not lose focus in the first place.

I tested video again today, this time using the "custom" focus (a sort of diamond-shaped pattern of AF points). (I had previously used the "Center area" AF). Changing to "custom" didn't solve the problem; in fact in some cases it was worse if the camera got interested in something at the edge of the AF pattern.

I'm finding this very disappointing since I've had many different Panasonic cameras over the past years (GH3, GX6, GX7, GX85; FZ150, FZ300, ZS50, etc.) and NONE of them have been like this. Yes, there has been the occasional slight blur (quickly corrected) but not this back and forth from focus to slightly OoF.

I'm starting to think I got a defective unit; I may have to send it back.

Sorry can't help you with this one, when I use my G9 for video I typically either have Continuous AF with face detect, or go manual focus entirely so I have no experience with the other AF patterns.

 Adrian Tung's gear list:Adrian Tung's gear list
Sony RX100 III Olympus Stylus Tough TG-870 Sony RX100 VI Olympus PEN-F Panasonic Lumix DC-G9 +12 more
Post (hide subjects) Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow