Lens Update - Problems with A7RIII on Mac running Mojave

Started Jan 18, 2019 | Discussions thread
ForumParentFirstPreviousNext
Flat view
MRK 2010 Regular Member • Posts: 180
Lens Update - Problems with A7RIII on Mac running Mojave

Help!

I decided I should finally update a couple of my lenses to the latest Firmware versions (SEL70200g, SEL55F18z and a few others)

However I can't get the Sony Lens updater software to work.

I've followed the steps numerous times and it tells me no update could be performed as the camera could not be found

I've installed the driver beforehand as instructed (DriverLoader_1013 for SEL80200g and SEL55F18z) but it doesn't make a difference

The USB connection is set to mass storage. I've removed the memory cards. But the system just won't detect or recognise the camera

Interestingly the camera is shown as PMHOME when I connect it to the Mac - I assume this has something to do with PlayMemories home

It's driving me mad .....I managed to update to the camera firmware version 2.10 earlier this week so it's not the cable

Any advice on how I can get the Lens Updater to work on a Mac running Mojave version of MacOS would be really appreciated!!!!

Thanks

Matt

 MRK 2010's gear list:MRK 2010's gear list
Sony RX100 II Sony a7
ForumParentFirstPreviousNext
Flat view
Post (hide subjects) Posted by
ForumParentFirstPreviousNext
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow