D300s w/ grip - Can't get 8fps

Started 1 week ago | Discussions thread
OP saskskier Regular Member • Posts: 137
Re: D300s w/ grip - Can't get 8fps

Did detritus wrote:

saskskier wrote:

detritus wrote:

saskskier wrote:

(I feel like someone is going to point out something ridiculously obvious, in which case, I'm sorry)

Sadly so, but it happens to everyone from time to time! As others have explained, CL is the "low" speed setting, which you can customise to select a lower FPS if desired. CH will give you the fastest rate available, 8 FPS.

I almost always shoot in CH. Is there going to be any place that says I’m shooting 8fps or will it automatically adjust?

It's been a while... But if I remember correctly, hitting the info button which displays the camera settings on the rear lcd, it would show 8 FPS with the grip attached.

Providing there are no other settings or factors lowering the FPS as listed by the other posters. (whether or not the camera is actually achieving the reported 8 FPS is another question!

Did this yesterday. Getting 7.7 FPS, as I should be with AA’s. Initially, the CL setting was throwing me off (thanks for clearing that up!). It felt like it was shooting quickly, but didn’t know if there was a place that would actually tell me how many FPS I was getting. Pressing “Info” cleared that up.

Thanks everyone!

 saskskier's gear list:saskskier's gear list
Nikon D80 Nikon D300S Nikon D5100 Nikon AF Nikkor 50mm f/1.8D Sigma 17-70mm F2.8-4 DC Macro OS HSM +3 more
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow