My First Pro-1000 Print Experience (and Firmware Update)

Started 3 weeks ago | Discussions thread
ForumParentFirstPrevious
Flat view
SaltLakeGuy
SaltLakeGuy Forum Pro • Posts: 13,875
My First Pro-1000 Print Experience (and Firmware Update)
3

I finally opened up my Pro-1000 to set it up after I received my desk for it from Wayfair which is the perfect size and nicely sturdy as well let alone fitting in the corner of my office perfectly.First let me say the setup procedure Canon provided via their LCD instructions were brilliant and you virtually can't mess things up as you go along. It all went smoothly including my WiFi setup as I had NO intention of laying a USB or Ethernet cable across the entire length of the floor just to get to the computer tower. Some seem to be very negative on this setup but frankly it went delightfully  smoothly and has thus far provided a nice brisk print affair, not slow as reported.

Also let me say that contrary to many a Youtube video and people on various forums (and yes even Canon's own instructions) there is an ERROR regarding Firmware update procedure. If one has WiFi set up as I do, it will accomplish ALL procedures that the printer can possibly offer with NO loss of function whatsoever......NONE! It was easy to just go to the menu, select Fireware update and away it went downloading AND installing it in fairly short order no issues. I wanted you all to know this just in case you are not a wired fanatic (as I am NOT if it's messy) and prefer a neat layout in your office for convenience. Indeed it works flawlessly in all regards without a Ethernet nor USB. I am on a fairly high speed connection on my router (120mbps) cable using a top line Netgear whether or not those are a significant effect of it's performance.

The print came out quite quickly set to the first setting below the ultimate. I see no flaws in it and am especially pleased it matches the screen virtually perfectly regarding exposure, color and rendition from the DXO PhotoLab 2 program. Yes indeed the cartridges all show as about 1/2 full after all the setup and printing has been completed. Same with the waste tank (which I got an extra one of just in case down the line). Thus far I'm very pleased with the incredible sharpness, detail and color rendition it's been providing so far. Here's to hoping it keeps working nicely as it is right now. Here's a quick pic of my setup and that first print.

-- hide signature --

A member of the "Been There Done That" club. Owned nearly every camera brand and type you can name along the way.

 SaltLakeGuy's gear list:SaltLakeGuy's gear list
Sony RX10 IV +11 more
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow