Sigma 85 EX: Suddenly anti-D800!

Started 4 weeks ago | Discussions thread
ForumParentFirstPreviousNext
Flat view
WhoAmI5423 Forum Member • Posts: 93
Sigma 85 EX: Suddenly anti-D800!

Here's a fun issue I thought I would share!  I have had a Sigma 85 EX for almost 8 years now.  By far my favorite and most-used lens I own.  Anyway, I was at a wedding rehearsal this evening using my backup D800 (firmware v1.11) and it would not focus.  In fact, pressing the AF mode button (left side - choose between AF-S/-C, 3D, D9, etc) completely fails to work when the 85 is attached (i.e. doesn't come up.).

Now, when I got home and put it on my primary body (D850) - it worked like a charm!  In fact, I can move it between the 2 cameras and, predictably, it works fine on the D850 and fails on the D800!  I can use my other lenses fine on the D800 (Sigma 35 Art, Sigma 24 Art, Sigma 135 Art, Tamron 90mm Macro) which really adds to the confusion.

So far, I've cleaned the contacts on the lens and have left the battery out of the D800 for a while to see if things cleared up - no help.  I have a support request in to Sigma (although they probably won't respond until Monday at the earliest).  The only other thing I can think of is that I don't know if I've tried the 85 since upgrading the D800's firmware.  Given the age of the 85, I wonder if there could be an issue now?

 WhoAmI5423's gear list:WhoAmI5423's gear list
Nikon D800 Nikon D850 Nikon AF-S Nikkor 16-35mm F4G ED VR Nikon AF-S Nikkor 70-200mm f/2.8G ED VR II Tamron SP AF 90mm F/2.8 Di Macro +6 more
Nikon D800 Nikon D850
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNext
Flat view
Post (hide subjects) Posted by
ForumParentFirstPreviousNext
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow