Frequent sensor dust in A7RII?

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
SamKnopf Regular Member • Posts: 434
Frequent sensor dust in A7RII?

I recently upgraded to an A7RII. I'm aware that sensor cleaning is a menu option, and I have used it several times. However, it does not clear all the dust and I have to go in and clean out the dust manually.

This is for landscape photos where I use a small aperture, where dust spots show up in the sky area. Even at f/8 they are visible, and at f/11 become quite a problem.

The last time I had a problem with dust showing up in my photos was years ago with the old Canon 5D that had no sensor cleaning function at all. Since then, I have used M43, Sony APS-C, and a Sony A7, and never saw dust in my photos until the A7RII.

Have others also found that the A7RII has more problems with dust? I thought at first that it might perhaps be the higher megapixel count, but that can't be right. M43 has denser pixels. Each dust particle would get magnified even more on the smaller sensor, but I've never had a problem there.  (On M43, the sensor cleaning is automatically applied every time the camera is powered off.)

One possibility is that it's just that I change lenses more often on the A7RII, as I am more inclined to use primes to take advantage of its higher resolution, whereas with the A7 I mostly just kept the kit lens on it.

 SamKnopf's gear list:SamKnopf's gear list
Sony a6000 Panasonic Lumix DMC-GM5 Olympus E-M5 II Sony a7R II Panasonic Lumix DMC-GX8 +1 more
Sony a7
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
Trk
Trk
Trk
Trk
CE3
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow