Need help with strange circular artifact on EM-1 mk. ii photos

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
Mephistopheles* Regular Member • Posts: 276
Need help with strange circular artifact on EM-1 mk. ii photos

I've taken about 20,000 photos with this camera, and a few weeks ago I noticed for the first time a strange bright orange artifact appearing on three photos out of hundreds I shot that day. (And no, I am not talking about the sun). I'm guessing it is some type of sensor glitch. It has not reappeared in that exact form, but ghosts of the same shape seem to be showing up in photos I took yesterday. Examples of the original artifact and the ghosts are attached. However, the ghost is not appearing in the same location on the sensor as the original artifact.

I guess the main questions are is this a serious concern that will likely continue, and if so, is there anything I can do to correct it short of replacing the sensor.

Spangled Skimmer with orange artifact just beneath the thorax.

Halloween Pennant; possible artifact ghost to the right

 Mephistopheles*'s gear list:Mephistopheles*'s gear list
Olympus E-M1 II Panasonic Lumix G Vario 100-300mm F4-5.6 OIS Panasonic Leica 100-400mm F4.0-6.3 ASPH Olympus M.Zuiko 300mm F4 IS Pro Panasonic Lumix DMC-FZ18 +6 more
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow