Sigma lenses have clicking rattle noise

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
Davi7d777
Davi7d777 Regular Member • Posts: 247
Sigma lenses have clicking rattle noise

I have an A6000 bought at the 2014 release with the Sony SEL1650, SELP55210, and E 3.5/30 MACRO. Also bought the Sigma F2.8 30mm, 60mm, and 19mm DN lenses. Have recently found a need to do videos using the wide 19mm Sigma however discovered a constant low variable clicking rattle issue that per other threads I searched for has also been noticed by others. Some of those other threads predate the A6000 and it appears there is more than one noise issue people have been discussing and has been a deal breaker for some others also doing videos.

The low clicking rattle is of concern only capturing videos because the sensitive A6000 microphones readily picks up the constant sound like some lens internal motor mechanism repeating movement. Because there is no external microphone feature on the A6000 it has become a deal breaker for my purposes. The rattle sound DOES NOT OCCUR at all with any of my 3 Sony lenses while it does occur on ALL the Sigma lenses. It occurs constantly and is not affected by settings though does seem to possibly vary with various operations like actuating the shutter. And that includes going into Manual including Manual focus or changing any of the video mode or settings. The Sigma F2.8 19mm has otherwise produced fine stills though I don't use it much. Note one of the noise issues mentioned online was about changing aperture blades however that is not this issue as the aperture is still in Aperture Priority mode.

I would use my SELP1650 except it went bad after a few months of use in 2014 with erratic operation including an intermittent "lens not recognized" issue.  Thus am facing buying a replacement lens that does not make these sounds and it looks like I may buy another SELP1650 from Walmart for $148. Thus am first bringing this up here in case I am missing something about the issue.

Of interest would be to understand whether other members with the A6000 and Sigma lenses all have this noise issue or if some do not?  Note to test if so put your ear to the camera at a quiet location and note it does not require going into a video recording though the sensitive mic will pick up the sound much more readily during recording.

David

 Davi7d777's gear list:Davi7d777's gear list
Canon PowerShot G10 Canon PowerShot SX130 IS Nikon Coolpix S3100 Sony a6000 Sony E 30mm F3.5 Macro +9 more
Sony a6000
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow