Yongnuo YN24EX twin flash user experience + diffusers

Started Jun 29, 2017 | Discussions thread
pikeface Contributing Member • Posts: 532
Re: Yongnuo YN24EX twin flash user experience + diffusers

SteB wrote:

I haven't personally had this problem whilst using mine mainly the the Canon 80D. However, I have had similar problem with the Yongnuo YN14EX on the Canon 80D and Canon 70D. It worked fine on the Canon 40D and 600D. You don't say which camera you have. I assume the problems with the YN14EX, but not YN24EX were because the 70D and 80D were released after the flashgun was released. This is a problem with many of these flashguns in that the interface with the camera was back engineered and so the flash only fully functions with the cameras that it was tested on, but not later models. I can't be certain that this is the problem with yours. However, Canon has brought out DSLRs after this flash was released.

I am using a 1DX mkII and a 5dSR the SR is more reliable than the DX.  I have found that if you change the ISO on the camera without pressing ok the flash misfires for 5sec, however id you press ok to accept the ISO change its fine.

The other thing I have tried is to isolate the four pins on the shoe with tape so that the camera can't feed back to the body, this seems to work 100% but you have to turn the less on from flash gun.

I did look for a firmware upgrade but no luck yet.

-- hide signature --

Have a look and leave a message
http://www.pictures-4u.co.uk

Post (hide subjects) Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow