Hot pixel mapping for the C-2100 UZ works!

Started Sep 5, 2003 | Discussions thread
James H. Contributing Member • Posts: 719
UZI Pixel Remap Successful

I made a serial cable using a Radio Shack 3/32" Stereo Phone Plug on one end a female DB9 connector. Soldered all pins exactly as diagramed from the link provided by Corhoin ( http://forums.dpreview.com/forums/read.asp?forum=1008&message=6031586 ).

I then let the Uzi sit and warm up (with LCD on, auto OFF disabled) for 15 minutes. I then ran the program and the camera connected the first time.

============================

I then clicked the "Read" button and the entire proccess gave the following messages in the window of the program:

SR95A
FIRMWARE: v352u-74
S/N: #00000001
Reading the defect pixels.
Elapsed time: 25 sec (100%).
Read 16 defect pixels.
1 1438 43
2 588 539
3 1157 443
4 1082 168
5 1535 1184
6 1278 12
7 383 189
8 1099 376
9 401 877
10 1242 395
11 1118 606
12 1132 682
13 993 505
14 416 67
15 616 439
16 20 1126

============================

Next I clicked the "Remao" button and this proccess returned:

SR95A
FIRMWARE: v352u-74
S/N: #00000001
Remapping the defect pixels.
Remap complete. (23 sec)
It's been found 512 defect pixels.

============================

Once that is done, I clicked the "Read" button again just to see any difference:

SR95A
FIRMWARE: v352u-74
S/N: #00000001
Reading the defect pixels.
Elapsed time: 25 sec (100%).
Read 16 defect pixels.
1 1438 43
2 317 687
3 562 124
4 902 980
5 1130 1022
6 588 539
7 1157 443
8 1535 1184
9 1082 168
10 1278 12
11 1242 395
12 815 870
13 993 505
14 383 189
15 1099 376
16 1503 660

============================

In the end, the 3 hot pixels I got at 1/2 sec. seem to be gone even at 4 sec. The following link gives pictures of my cable as well as the hot pixel tests I did: http://www.dotphoto.com/go.asp?l=jamestr&AID=1026199

Happy Remapping!

James H. wrote:
Holland,

This is great that more than one person has used this program
successfully. I think that gives me enough confidence to try it on
my 2100. Going to start making the cable now. I currently get 3 hot
pixel at 1/2 sec, 2.8f and my 1 year Oly warranty is up. I only
have the CompUSA extended warranty and I think they'd rather
re-emburse the cost than send it to Olympus for repairs. But this
would allow me not to have to worry about getting it sent in at
all. It'd Be nice to get rid of those 3 hot pixels.

A question for you:

When doing your serial cable, did you short pin 4 to pin 6 and 7 to
8 as the diagram suggest?

Thanks,

James.

HOLLAND STJOHN wrote:

Turned out that the serial cable I was using was from a Fuji
camera, I had assumed the pinouts were the same as Oly, but thanks
to your pinout info I found it was not. I didn't have an Oly serial
cable, but did have 2 Fuji cables, so I cut one and rewired
according to your pinout.... Program works perfectly.

Dead pixel test at 16 sec iso 100 was 10 hot pixels before
remapping, Zero after remapping.

Read Pixel count was 16 before remapping, zero after remapping.

Remap found 206 defective pixels that were remapped.

Looking at 16 sec dark frame shot in photoshop without adjustments
shows the one easily seen majenta pixel now gone.

This is not a big deal now as my camera really wasn't too bad
anyway, but I know that dead and hot pixels accumulate over time,
and my extended warrantee runs out in about 6 months... Now I know
I can easily remap bad pixels a year from now if I need too.

THANKS!!

Holland

Holland
C21oo(2 UZIs, just in case...), B3oo, E1ooRS, FL-4o

-- hide signature --

James H.
Oly C2100Uzi & Oly C-3000z (until I sell it)

-- hide signature --

James H.
Oly C2100Uzi & Oly C-3000z (until I sell it)

Post (hide subjects) Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow