D750 auto-iso behaves differently w/ different flashes

Started 6 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
theJrod Regular Member • Posts: 213
D750 auto-iso behaves differently w/ different flashes

I have a D750 that I use with a SB800 and a Godox 685. I’ve noticed that depending on which flash I use, I get different behavior from auto-iso - all settings equal.

D750: M mode, auto-iso 100-12800, flash comp 0.0.

Each flash is set to TTL.

With either flash mounted to the hot shoe and turned on, the iso floor jumps to 400.

With Nikon SB800 though, the pair seems to attempt to keep iso low by increasing flash power. Typical indoor snaps have an iso of 400-1600, with the flash obviously firing at a high-ish power.

With the Godox however, there seems to be some priority on minimizing flash power and increasing iso to get optimal exposure. The exact same shots taken with the Godox have iso in the 8000-10,000 range.

Increasing flash exp comp just seems to overexposed the images.

Many tips? I’d like the Godox to behave more like the SB800.

 theJrod's gear list:theJrod's gear list
Nikon AF-S Nikkor 70-200mm f/4G ED VR Nikon D750 Nikon AF-S Teleconverter TC-14E II Nikon AF-S Nikkor 24-120mm f/4G ED VR Nikon AF-S Nikkor 50mm f/1.8G +1 more
Nikon D750
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow