E-M10 Mk II Broken? Or Normal for Keep Color Warm?

Started 8 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
Jambon Junior Member • Posts: 44
E-M10 Mk II Broken? Or Normal for Keep Color Warm?

I recently bought an E-M10 Mk II used. It had less than 1000 shutter count and no physical evidence of drops  or other damage.

When I got it home I immediately performed a full reset and fired it up in Auto mode for starters, I was horrified at the white balance under indoor lighting. Outside under natural lighting, the white balance was fine. I quickly discovered the Keep Color Warm setting which made a big difference inside, but the default setting white balance was so extreme that I'm concerned that the camera is defective. This might be an issue as I was hoping to have this be a shared camera and if I can't set it to Auto and hand it to a spouse it becomes useless for indoor photography for her.

So my big question now is if the device is defective. If it turns out not to meet my needs, can I even sell it in good conscience? Any advice on how to determine if this is normal or not for this model?

Here are a couple of blurry sample photos which demonstrate the white balance:

Program Mode - Keep Color Warm Off

Auto Mode

 Jambon's gear list:Jambon's gear list
Canon EOS M6
Olympus OM-D E-M10
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow