Olympus E-5 Studio Strobe Issue

Started 9 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
Aoresteen Regular Member • Posts: 426
Olympus E-5 Studio Strobe Issue

I am trying to get my studio strobes (White Lighting Zap 1000s) to work with my E-5. It's so simple my 1968 Pentax Spotmatic SL can do it. My 2010 E-5 can't seem to make the strobes fire consistently.

I am pretty sure that the fault lies with the guy standing behind the camera.

The strobes are working fine. I am triggering them with a radio trigger unit (Wansen PT-04). Tested them with a Pentax Spotmatic via a PC cord and everything works fine . Tested them with a Pentax ESII via the hot shoe and everything works just fine. Each time I trip the shutter the strobes fire. Never misses a beat. Ah, I love old school mechanical cameras.

The radio trigger shows 3.6 VDC on the trigger which is safe the the E-5.

I read page 82 of the E-5 manual on how to use commercial flash units. Radio trigger is in the E-5's hot shoe. Mode is set to M. Shutter speed is set to 1/250th. Apertures is set to f/8. The first time I press the shutter the E-5 fires the strobe. Second time I press the shutter is does NOT fire the strobes (camera does fire - I get a very dark picture of course). 3rd time it fires. 4th time it does not. 5th time it fires. 6th time it does not.

It only fires the strobes every other time.

Any ideas on what I need to do to get the E-5 to fire the strobes EVERY time? I must have something set wrong but for the life of me I can not find it.

Thanks!

EDIT: I decided to by-pass the radio trigger and test the E-5 corded to the strobes, Since the Zap1000 has a trigger voltage of 10.5 VDC (Olympus now says the safe trigger voltage is 6 VDC), I put my Safe-Sync adapter on the E-5 and plugged in the strobe sync cord. The strobe fires every time.

Something happens when the E-5 is connected to the radio trigger. Very strange.

 Aoresteen's gear list:Aoresteen's gear list
Olympus C-7070 Wide Zoom Olympus E-1 Olympus E-3 Olympus E-5 Olympus Zuiko Digital ED 50mm 1:2.0 Macro +12 more
Olympus E-5
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow