I have had it with MS and HP

Started 8 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
Jim B (MSP) Veteran Member • Posts: 9,028
I have had it with MS and HP
5

This is more of a rant than it is looking for help.

Background, I have a 3 yr old HP Envy 17, with a SSD for the C Drive (I installed)

It worked fine under Win 7.

Win 10 comes along, and it won't completely shut down. I tried multiple fixes.

After the 3rd major update to Win 10, start up time went from 30 sec to 3 min. Again, multiple fixes did nothing.

I have updated the bios, and all drivers.

Just within the last few days, it refuses to take the newest update - an error that says either missing or damaged files.

Since I just built a new desktop aimed at Lightroom and Photoshop, I had some time to play with the laptop. BTW, desktop is just fine.

So I used the Windows built in fix - erase everything, and download a new Win 10. You would think that what I downloaded today would be up to date.  But no, it needs an update.  When that is downloaded - it fails to install (multiple times). Same error.

I have gone through all the fixes I can find on the internet. I have had HP install 2 new drivers.  All to no avail.  The download doesn't install.

All I have left is to remove Norton Internet Security - the only software added along with Chrome.

The pc will not completely shut down.

It still takes multiple minutes to start up.

UGH

JIm

-- hide signature --

Jim
"It's all about the light"

 Jim B (MSP)'s gear list:Jim B (MSP)'s gear list
Canon EOS 80D
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
(unknown member)
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow