RX10M2 Flash is Dead!

Started Nov 22, 2017 | Questions thread
ForumParentFirstPrevious
Flat view
quicky422 Regular Member • Posts: 454
RX10M2 Flash is Dead!

I use the camera almost on a daily basis.  I'm always careful with the built in flash

BUT

this morning, I went to use the flash, it went off but with a loud pop!  And that sound is never good!  Also, the smell of burnt electronics!

It doesn't fire now and it looks like the wiring coming out of the camera body has shorted.  It looks internal to the wire harness, like two wires may have touched....UGH.

It'll cost about $350 to repair through Sony.  Any experience with their repair service?  Are there other options for repair?

Also, I was looking at the HVL-F20M at a cost of $150.  Not sure if I'll go that route as I like to use flash minimally and I like the convenience of having the pop up flash only when needed.  How is this unit and do you think it's worth trying out?

I may just send it in for repair but after the Holidays, so I may try out the external flash for the time being but would like to hear some other thoughts, TIA.

 quicky422's gear list:quicky422's gear list
Kodak DX6440 Kodak EasyShare Z990 Sony Cyber-shot DSC-HX200V Sony RX10 II
ANSWER:
This question has not been answered yet.
Sony RX10 II
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow