my fix of the K-30 aperture problem without disassembly

Started 8 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
frozenshiver New Member • Posts: 3
my fix of the K-30 aperture problem without disassembly
22

Hi there

A few days ago I got a problem with my K-30. Until now I didn't knew, that this seems to be a common problem with the K-30 / K-50 series.

Pictures I have taken were totally underexposed. So obviously there must have been an error with the aperture control. Also in live view an underexposed preview was shown.

I just did the following and since then, this error never ever occurred again:

1.) Go to the camera menu to button customization and define the raw/FX button to "optical preview".

2.) Use Manual or AV mode and dial in an aperture other than open wide.

3.) Press the raw/FX button 10 to 20 times ( I did so). Every press you should hear the aperture lever working.

4.) Take some shots. At this point my K-30 did correct exposures with some exceptions. So I repeated the procedure until no wrong exposure occurred. I had to repeat step 3.) 3 times. Since then my camera works without any errors.

Maybe I was just lucky that this trick brought my copy back to working condition. Maybe if you have the same problem give it a try and your camera comes back to life again.

Cheers

Pentax K-30 Pentax K-50
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow