D500 Auto ISO - Gets 'Stuck'?

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
Steak Face Junior Member • Posts: 42
D500 Auto ISO - Gets 'Stuck'?

Hi all,

I was using my D500 at a function on Saturday night, my sons 21st.

At one stage I set the camera to manual and ISO 25,600 (just to experiment) as it was a dark environment.  I then chucked the flash on (SB600) and put the camera in P mode and Auto ISO to make sure I got the shots of him cutting cake etc. I'm not super confident in manual, especially with a flash so I thought I was playing it safe.

I took a bunch of flash photo's to only realise that the ISO was still at 25,600, even though it was on auto ISO.  Needless to say the photo's are pretty much a bin job.

I've noticed this before as well, that when I switch from manual ISO back to Auto ISO that the ISO value stays at the manual setting.  So I'm in manual mode and switching from manual to auto ISO the ISO stays at the previous manual setting regardless of changes in light.

To force it into auto ISO I turn auto ISO back off and on, change exposure modes, turn camera off and back on etc until ISO starts changing itself in response to lighting conditions (I'm not sure what method actually gets in back into auto ISO...).

Anyone else experienced this or am I doing something wrong?

To change from manual to auto ISO I hold down the ISO button and rotate the front command dial.

Cheers

 Steak Face's gear list:Steak Face's gear list
Nikon D500 Nikon AF-S Nikkor 50mm f/1.8G Nikon AF-S Nikkor 85mm f/1.8G Nikon AF-S Nikkor 20mm f/1.8G ED Nikon AF-S DX Nikkor 16-80mm F2.8-4E ED VR
Nikon D500
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow