RX10iv clunk noise

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
Horacecoker Senior Member • Posts: 1,306
RX10iv clunk noise

I'm a bit bothered about my RX10iv as it makes a fairly obvious click or clunk sound when I point the lens down and bring it level again with the camera switched off. There is obviously something loose and moving in the lens. It doesn't do it when the camera is switched on and the lens extends to it's normal wide angle position but on various other focal lengths it will make the same noise but not as loud. I can't remember my RX10iii making this sound or if it did not to the same extent that it would worry me.

Can people with the RX10iv please check theirs for me and even folk with the RX10iii. Holding the camera near your hear while moving the camera from horizontal to vertical and back is the best. Although with mine I can hear the sound quite clearly without doing that. It's at its loudest when switched off.

I've a couple of weeks left on the 30 days return policy. Which leads me to ask this question - is it possible to take the Sony glass LCD protector off the LCD without leaving any trace and could it then be reused?

Thanks for your help.

David

Quick update. I have now identified the source of the noise and can replicate it by holding the end of the lens and gently pulling it back and forth. There is enough movement to make the clunk, there is also movement in a circular direction. This is no movement when the camera is switched on at any focal length so I'm not as bothered now but would still like folk to have a fiddle with theirs and report back.

Thank you again

David

 Horacecoker's gear list:Horacecoker's gear list
Sony RX100 III
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow