Intermittent brightness/darkness issue with Sony Alpha e-Mount cameras

Started 2 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
Seibertron
Seibertron New Member • Posts: 20
Intermittent brightness/darkness issue with Sony Alpha e-Mount cameras
1

I am currently using the a6500, but can confirm that I have experienced this problem with regularity in both the NEX 5N, NEX 5T and the a5100.

The basic problem is this ... the camera intermittently changes the brightness or darkness of the display without actually changing the values of the aperture or shutter speed upon power cycling the camera (turning off, then on). I swear this happens occasionally with powering on the camera from an off state, however I was only able to replicate it just now by turning off the camera, pulling out the battery, putting the battery back in and turning the camera back on.

I don't know what to technically call this problem or how to properly describe it, but attached are some photos that I just took to demonstrate the problem.

As I mentioned at the beginning of this post, I was able to reproduce this problem on the NEX 5N, 5T and a5100, but these photos are currently from the a6500.

I am currently using the SEL30M35 macro lens, which I replaced about a year ago, but also encounter this problem with my SEL18200 lens as well.

Here are a series of raw images demonstrating the problem, which I uploaded to my website. These are rough images just demonstrating the problem with the darkness and lightness.

I don't think it's a lens or a camera specific problem. It seems to be a problem with NEX and Sony Alpha e-Mount cameras in general. Any suggestions on how to fix the problem or even a "that's a common problem we all deal with, welcome to the club" message would be alright too!

New battery, just turned on.

Turned back off, then back on and now it looks like how it should.

 Seibertron's gear list:Seibertron's gear list
NEX-5T Sony a6500 Sony E 18-200mm F3.5-6.3 OSS Sony E 30mm F3.5 Macro Sony E 16-50mm F3.5-5.6 PZ OSS +1 more
Sony a5100 Sony a6500
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow