5D3+50mm STM: blurry images

Started 2 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
mbrick New Member • Posts: 9
5D3+50mm STM: blurry images

I shot a wedding recently for a friend and had around 50% of the images I shot at f2.0-3.2 come out blurry.

They don't look just out of focus, but have an odd pastel-like look to them???
It's not as clear in these exports but when reviewing in 1:1 in LR, they look like something was wrong. It's very obvious going from a good image to one that was bad. I can try and post cropped 1:1 if it's hard to see below.

I've drawn a box for what the camera shows as the focus point in playback mode.

Shot on 5D3 with in Av mode at f2.0-3.2 with back button focus.
I confirmed last night the camera agreed it was focused by taking an image without first focusing, and the red box will not show up.

I included three images from the days before while I was practicing that were perfectly sharp and I was very happy with.

So, what is going on here?
I am OK because I also shot each in auto with flash so I do have usable images.

Sharp focus.

Sharp focus.

Sharp focus.

Blurry.

Blurry at all depths.

Blurry.

Blurry at all depths.

 mbrick's gear list:mbrick's gear list
Fujifilm X100T Canon EOS 5D Mark III Canon EF 70-300mm f/4-5.6L IS USM Canon EF 24-105mm f/4L IS USM Canon EF 50mm f/1.8 STM
Canon EOS 5D Mark III
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow